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Installation
Si vous utilisez les machines de la salle informatique, les programmes étant déja installés, vous pouvez
directement passer a I'étape d’utilisation (étape 13).

Installation de Python
Pour utiliser PyCharm, il est nécessaire que Python soit installé sur votre ordinateur. Si ce n’est pas le
cas, Python peut étre téléchargé a I'adresse suivante : https://www.python.org/downloads/. Assurez-

vous de bien noter dans quel dossier vous I'avez installé.

Installation de PyCharm

PyCharm est un IDE (Integrated Development Environment). |l s'agit, tout comme jEdit, d'un logiciel
permettant d'intégrer dans une méme fenétre tous les éléments utiles a la programmation en python
: un éditeur de texte pour écrire des scripts, une console pour exécuter des programmes, ainsi qu'un
explorateur de fichiers pour parcourir le projet en cours.

En tant qu'étudiant, vous pouvez utiliser la version professionnelle de PyCharm gratuitement. Pour
cela rendez-vous sur la page https://www.jetbrains.com/student/ et appuyez sur le bouton Apply
Now. Vous serez amenés sur une page vous demandant votre nom et prénom, ainsi que votre adresse
email académique. Il est ici important d'entrer votre adresse UNIL. Vous recevrez ensuite un email

avec des instructions sur la facon d’activer votre licence. Suivez-les. Il vous sera demandé de créer un
compte JetBrain (la société produisant PyCharm). Il vous suffit de créer un identifiant (vous pouvez
utiliser votre adresse email de I'Unil comme identifiant facile a retenir), ainsi gu'un mot de passe. Une
fois connecté a votre compte, vous pourrez télécharger la version Professionnelle de Pycharm.

Vous pouvez maintenant exécuter l'installeur de PyCharm que vous venez de télécharger en double
cliquant dessus. Pour les utilisateurs de Mac, il se peut que vous deviez autoriser l'installation
d'applications externes. Pour cela, allez dans l'application Préférences Systeme, puis dans l'onglet
Sécurité et confidentialité. Ici vous pouvez ouvrir le cadenas et cocher I'option N'importe od.

1. Cliquez sur Next.

& PyCharm Setup - X

PC Welcome to the PyCharm Setup
Wizard

This wizard will guide you through the installation of
PyCharm.

It is recommended that you close all other applications
before starting Setup. This will make it possible to update
relevant system files without having to reboot your
computer.

Click Next to continue.




Ici vous pouvez choisir le dossier ol vous voulez installer PyCharm. Next.

& pyCharm Setup - X
[ Choose Install Location
Choose the folder in which to install PyCharm.
Setup will install PyCharm in the following folder. To install in a different folder, click
Browse and select another folder. Click Next to continue.
Destination Folder
E:\PyCharm\PyCharm 2016.3.2 I | Browse...
Space required: 580.0MB
Space available: 708.5GB
< Back Next > Cancel

Ici vous pouvez cocher la case Create associations

.py. Ensuite, faites Next.

& pyCharm Setup - X

[ Installation Options
Configure your PyCharm installation

Create Desktop shortcut

[]32-bit launcher

Create associations

[.py

< Back Cancel

4. Cliquez ensuite sur Install puis sur Finish, une fois I'installation terminée.



Utilisation

Configuration initiale
Pour cette premiére utilisation, nous allons configurer PyCharm. Une documentation compléete de
PyCharm est disponible a I’adresse https://www.jetbrains.com/pycharm/documentation/.

5. Démarrez PyCharm

6. Sélectionnez | do not have... puis appuyez sur OK

& Complete Installation X

You can import your settings from a previous version of PyCharm.

Ot

tings |

Specify config folder or installation home of the previous version of PyCharm:

(@ 1 do not have a previous version of PyCharm or I do not want to import my settings

7. Acceptez les conditions d’utilisation

= PyCharm Privacy Policy Agreement X
Please read and accept these terms and conditions:
JetBrains Privacy Policy
Last updated: 14th March 2016
This Policy may be amended from time to time. The respective latest version of the policy at
the point of time of the purchase/registration of a JetBrains Software Product
(whichever occurs later) shall apply. The data controller is JetBrains s.r.o., Praha 4, Na
hiebenech II 171810, PSC 147 00, Ceska republika.
In this Privacy Policy, we describe the type of data, including personal data (collectively,
“data"), that we collect from you when you use our Website (listed under JetBrains
WebSite) and certain JetBrains products and services as described in this Privacy Policy
(collectively, our “services”) and how we use and disclose that data. The following
definitions will be used throughout this Privacy Policy.
@ Definitions
@ Why We Collect Data
@ What We Collect
Reject and Exit

8. Sivous utilisez la version professionnelle, entrez vos identifiants puis cliquez sur Activate.

E PyCharm License Activation

@ Activate

(O Evaluate for free

a X

Buy PyCharm

Activate license with:

(@ JetBrains Account () Activation code () License server

Username or email:

Password: For

Activate Exit

Sur la fenétre suivante, vous pourrez choisir les themes d’affichage des fenétres et de I’éditeur.
Ce sont des réglages esthétiques a effectuer selon vos préférences. Vous pouvez regarder les
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différents thémes proposés pour I'éditeur (Editor colors and fonts) et voir a quoi cela
ressemble en cliquant sur le bouton Click to preview.

9. Cliquez sur OK.
PyCharm Initial Configuration X

Keymap scheme: ‘ Intelli) IDEA Classic n
IDE theme: | Intelli) [ v |

Editor colors and fonts: | Default m
b Click to preview

You can use File | Settings to configure any of these settings later.

10. Cliquez sur Configure > Settings.

B Welcome to PyCharm — X

=

PyCharm

¢ Create New Project
Open

¥ Check out from Version Control +

 Events v

o>

Get Help ~

Plugins
Import Settings
Export Settings
Settings Repository...
Check for Update
Manage License...

11. Dans la nouvelle fenétre, allez dans I'onglet Project Interpreter puis cliquez sur la petite fleche
en haut a droite. Dans le menu déroulant, il devrait y avoir un chemin vers votre exécutable
pyhton python.exe. Sélectionnez le. Il est normal de ne pas observer la méme liste dans
I'exemple de tableau ci-dessous.



(Q
@

Keymap
Editor

Plugins

Version Control

Project Interpreter

Build, Execution, Deployment
Languages & Frameworks
Tools

Appearance & Behavior

& Default Settings

A

) Project Interpreter ct
. [ |
Project || # 360 E\ana ) n | % \l
Package Version Latest &%
Babel 234 234
Bottleneck 120 120
Cython 0252 0252
Flask 012 0.12
Flask-Cors 302 302
HeapDict 1.00 100
Jinja2 294 =» 295
MarkupSafe 023 023
Pillow 400 400
PyYAML 312 312
Pygments 213 =» 220
QtAwesome 043 = 044
QtPy 121 121
SQLAIchemy 115 115
Werkzeug 01115 01115
XisxWriter 096 096
_license 11
alabaster 079 079
anaconda 430
anaconda-client 160 122
anaconda-navigator 143
astroid 149 149
astropy 13 13
babel 234
backports 10 10
backports.shutil-get-terminal-size 1.00
beautifulsoupd 453 453

Kl o | Hep |

12. Allez ensuite dans l'onglet Build, Execution, Deployment > Console > Python Console.
Sélectionnez a nouveau le chemin vers votre exécutable python a 'aide de la fleche dans la
ligne Python interpreter. Sélectionnez ensuite le dossier ol vous souhaiterez faire vos
exercices dans la ligne Working directory, a I'aide du bouton sur la droite. Nous vous
conseillons de faire vos exercices dans un sous dossier de votre répertoire SwitchDrive. Cela
vous permettra d’y acceder depuis n’importe quel ordinateur ayant un accés a votre
SwitchDrive. Cliquez ensuite sur OK. Une barre de chargement apparait. Laissez la finir.

(Q
@

Keymap

Editor

Plugins
Version Control

Project Interpreter

Appearance & Behavior

& Default Settings

) Build, Execution, Deployment > Console > Python Console (- For ¢

~ Environment
Project: [none]

Environment variables:

X

Python interpreter: l # Python 3.6.0 (E:\Anaconda\envs\python36\python.exe)

Interpreter options:

Build, Execution, Deployment
Debugger
Python Debugger
Deployment
Buildout Support

Console

Python Console

Coverage
Docker
Docker Registry
Languages & Frameworks
Tools

el « ||

Working directory: | E:\Switch_Drive\Informatique_2\Exercices

Configure Interpreters
Add content roots to PYTHONPATH

[T Add source roots to PYTHONPATH

@ | Starting script

\ Cancel | | | Hep |

Ces

quelques

opérations nous ont permis d'indiquer a PyCharm quel Python nous souhaitons utiliser et ol
nous souhaitons travailler.



Travailler sur un projet

Nous allons commencer par créer un nouveau projet.

13. Appuyez sur Create New Project.

& Welcome to PyCharm

Yy
Py
PyCharm

¥ Create New Project

Open

¥ Check out from Version Control +

) Events v #* Configure v Get Help v

14. Sélectionnez ensuite I'onglet Pure Python et assurez-vous que le dossier de travail est celui

désiré (sous dossier SwitchDrive par exemple). Vous pouvez donner un nom au dossier du
projet. Appuyez ensuite sur Create.

B New Project = x
re Fyon | Location: | E:\Switch_Drive\Informatique_Z\Exercices\Demol H . ‘
(% HJ:::(9° Interpreter: 1 & 360at E\Anaconda\envs\python36\python.exe ﬁ
& Google App Engine

a Pyramid

Web2Py

Y Angular CLI

¥ Angular)S

@ Foundation

[ HTMLS Boilerplate

@ React App

& React Native

u Twitter Bootstrap

€ Web Starter Kit

& | Create J

15. Une fois arrivé sur I’écran principal de PyCharm, vous pouvez créer votre premier script
python. Pour cela, en haut a gauche, cliquez sur File > New... > Python File.



R eot View Nevigate Code Refactor Run Tooks VCS Window Help

New... Alt-Insérer )
3 Open... : T New |
Open URL... File
Save As.. I Directory
Open Recent [ Python Package
Close Project
% Settings... Ctrl+AltsS s Jupyter Notebook
Default Settings... a4 HTML File
Import Settings... E Syichea
2 iima JavaScript File
Epiines 2 TypeScript File
Settings Repository... [$ CoffeeScript File
H SaveAll Ctrl+S ) Gherkin feature file
O synchronize  Ctri-Alt+Y  Edit File Templates...
Invalidate Caches / Restart... B
| = Data Source
5 Print...
Add to Favorites
File Encoding B New Python file X
Line Separators
Make Directory Read-only | ame: foed |  Jn
Power Save Mode Kind: | & Python file
Exit

16. Le fichier sera automatiquement placé dans le dossier de votre projet.

B Demo - [EASwitch_Drive\Informatique_2\Exercices\Demo - ..\Demo.py - PyCharm 2016.3.2
File Edit View Navigate Code Refactor Run Tools VCS Window Help

1 Demo ) Demo.py ) Explorateur de fichiers

® Project - 67-‘1 | %~ 1= | @ Demoy
v I Demo E:\Switch_Drive\Informatique_2\Exercices\Demo

x|

St un programme de demo!

Demo.py
» Il External Libraries

Ta s m e

phrase = "Hello wvorld!"
print (phrase)

for 1 in range (len(phrase)) |

Explorateur de projet 55 princ(ie* "sphrase(i])

Editeur de texte

Accés aux consoles

17. Pour ouvrir un projet déja créé, allez dans 'onglet File > Open. De |3, vous pouvez ouvrir un
projet complet ou juste un script. Les dossiers contenants des projets apparaissent avec un
carré noir au coin du dossier. Pour I'ouvrir, sélectionnez le dossier ou le fichier voulu et faites
Ok.



& openFile or Project X

AERDR EX O & Hide path
| E:\Switch_Drive\Informatique_2\Exercices\Demo ﬁ
v Informatique_2
v Exercices

= Autre_projet_demo
> .idea
# autre_demo.py

> .idea

@ Demo.py

s . 1 . . . . N /
18. Pour exécuter votre script, allez dans I’onglet Run > Run”, puis cliquez sur le fichier a exécuter.

File Edit View Navigate Code Refactor mlools VCS Window Help
Run Maj+F10

Demo ) & Demo.py »
X Debug Maj+F9
7 Project v :

-g 5 Run with Coverage

= v Demo E:\Switch_Drive\Informatique,

o Profile

= ~ Demo.py : :

- » |llll External Libraries Concurrency Diagram for

o _

;:;5 ¥ Debug... Alt+Maj+F9

Z Attach to Local Process...

&

~1 [ Edit Configurations...

v 'El Import Test Results »
Stop Ctrl+F2

Show Running List

F8

Alt+Maj+F8

-

Alt+Maj+F7

Maj+F7

Step Maj+F8
Run to Cursor Alt+F9
Force Run to Cursor Ctrl+Alt+F9
Resume Program F9
Evaluate Expression... Alt+F8
Quick Evaluate Expression Ctrl+Alt+F8
Show Execution Point Alt+F10
Toggle Line Breakpoint Ctrl+F8

Toggle Temporary Line Breakpoint Ctrl+Alt+Maj+F8
Toggle Breakpoint Enabled

¢ View Breakpoints... Ctrl+Maj+F8

Run

0. F'l Edit Configurations...

Hold M3j to Debug

Une nouvelle zone apparait. Il s’agit de la console. C’est ici que vous observerez les résultats

de vos scripts.

19. Par défaut, I'output d’un script est renvoyé dans la console Run.

! Vous pouvez configurer les raccourcis clavier en allant dans les paramétres de Pycharm (File > Settings) puis dans
I'onglet Keymap.



| Run Demo

’ E:\Anaconda\envs\python3é\python.exe E:/Switch_Drive/Informatique_2/Exercices/Demo/Demo.py
Hello world!
H
=
1
=@
7 R
X L] b
o
? r
1

¥ 2:Favorites

Process finished with exit code 0

> 4:Run I » 6:TODO ¥ Python Console  [E Terminal

=

20. Vous pouvez aussi utiliser la console python pour effectuer des tests indépendamment de ce
que vous mettez dans vos scripts.

Python Console

CE In[2]:

]1: print("Ceci est la conscle python")
Ceci est la consocle python
In[3]: print(phrase)
Traceback (most recent call last):
File "E:\Anaconda\envs\python3é\lib\site-packages\IPython\core\interactiveshell.py”, line 2881, in run_code
exec(code_obj, self.user_global_ns, self.user_ns)
File "<ipython-input-3-b57262925cc4>", line 1, in <module>
print (phrase)
" NameError: name 'phrase' is not defined

@ & v v X

+ =

In[4]:

¥+ 2:Favorites

P 4Run =2 6TODO I #, Python Console I [# Terminal

Comme vous pouvez le voir, méme apreés I'exécution du script, les variables du script n’existent

pas dans la console python. Il est toutefois possible d’exécuter une partie de votre script dans
la console. Pour cela, sélectionnez les lignes a exécuter, faites un clic droit et appuyez sur
Execute Selection in Console. Faire cela produit le méme effet que si vous aviez tapé toutes
les instructions sélectionnées dans la console.



File Edit View Navigate Code Refactor Run Tools VCS

Window Help

1 Demo ) & Demo.py )

3
Y

B Projet (] #- -
v Demo E:\Switch_Drive\Informatique_2\Exercices\Demo
(# Demo.py

» Il External Libraries

«J 1 Structure

Python Console

@ Demo.py X

1 P

mme de demo!

"Hello world!"

(phrase)

Ctrl+X.
Cerl+C

= [ Copy
Copy as Plain Text
Copy Reference

[ Paste
Paste from History...
Paste Simple

Ctrl+ Alt+Maj+C
Crl+V
Ctrl+Maj+V
Ctri+ Alt+ Maj+V
Column Selection Mode Alt+Maj+ Insérer
Find Usages Alt+F7
Refactor »
Folding »
Search with Google
GoTo >

Generate. Alt+Insérer

G Inl4]: phrase = "Hello vorld!"
..: print(phrase)

for i in range(len(phrase)):
princ(i*" "+phrase[1i])

P Run 'Demo’ Ctrl+Maj+F10
#€ Debug 'Demo’

¥% Run 'Demo’ with Coverage

©p Profile 'Demo’

s O
it i £ Concurrency Diagram for ‘Demo
@ Save Demo’

L]

Local History »

-

-

Compare with
File Encoding

1% Diagrams »
r ©) Create Gist...

+ AR YU VY X

In[5]: phrase
out[s):
*Hello world!®

In(6]:

o 2: Favorites

»> 9‘:Run <2 §: TODO Terminal

21. Vous avez aussi acces a un terminal de commande de votre systéeme d’exploitation.

Terminal

+ Microsoft Windows [version 10.0.14393]
(c) 2016 Microsoft Corporation. Tous droits réservés.

X

(E:\Anaconda\envs\python3é) E: \Switch_Drive\Informar.ique_Z\Exercices\Demo)l

¥ 2:Favorites

@ Python Console

P 4Run & TODO
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Redirection de l'input et de 'output standard

22. Nous avons vu que normalement, le résultat d’un script (son output) est renvoyé dans la
console Run. Il vous est aussi possible de rediriger I'output dans un fichier. Pour cela, allez dans
I’onglet Run > Edit Configurations.... Allez ensuite dans |'onglet Logs et cochez la case Save
console output to file en choisissant le nom du fichier dans lequel vous voulez enregistrer

I'output.

B Run/Debug Configurations

+ -0 E ¥
# Python

Name: | Demo

 Defaults Log files to be shown in console

Is Active

Log File Entry.

X

[0 share [ Single instance only

Skip Content | 4

E:\Switch_Drive)

. 2\Exercic

Demo\output.tt

Save console output to file:

efore launch: Activate tool window

+

() Show this page Activate tool window

() Show console when a message is printed to standard output stream

[ Show console when 2 message is printed to standard error stream

=

| Help

23. 1l vous est aussi possible de faire ces redirections en utilisant le terminal de commande.

Terminal

4 |Microsoft Windows [version 10.0.14393]
% (c) 2016 Microsoft Corporation. Tous droits réservés.

(E:\Anaconda\envs\python36) E:\Switch_Drive\Informatique_2\Exercices\Demo>python Demo.py < input.txt > output.txt 2> error.txt

P 42Run 2 &TODO ¥ Python Console Terminal

Cette commande permet de dire a la machine d’exécuter Demo.py avec le programme Python,
de transmettre en input standard le fichier input.txt (< input.txt), de rediriger I'output sur le
fichier output.txt (> output.txt) et enfin de rediriger les erreurs dans le fichier error.txt (2>

error.txt).
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Installer des modules

PyCharm permet d’installer et de gérer des modules python a I'aide du module pip®. Pour cela, ce
dernier doit étre installé sur la machine.

24. Dans PyCharm allez dans I'onglet File > Settings.

25. Allez ensuite dans I'onglet Project > Project interpreter. Ici s’affiche la liste des modules déja

installés. Appuyez sur le plus en haut a droite pour ajouter un module.

& settings re
Q ) Project: Projet Demo » Project Interpreter o <
Appearance & Behavior Project Interpreter: ¥ 3,60 (E\Anaconda\envs\python36\python.exe) n *
Keymap
Editor Package Version Latest
Plugins Babel 234 234
Version Control Bottleneck 120 120
Cython 0252 0252
Project: Projet Demo Flask 012 012
Project Interprete Flask-Cors 302 302
Project Structure HeapDict 100 100
£ . Jinja2 294 » 295
e T MarkupSafe 023 023
Languages & Frameworks Pillow 400 400
Tools PyYAML 312 312
Pygments 213 » 220
QtAwesome 043 » 044
QtPy 121 121
SQLAIchemy 115 115
Werkzeug 0.11.15 0.11.15
XisxWriter 096 096
_license 1
alabaster 079 079
anaconda 430
anaconda-client 160 122
anaconda-navigator 143
astroid 149 149
astropy 13 13
babel 234
backports 10 10
backports.shutil-get-terminal-size 100
o I

26. Dans cette fenétre, vous pouvez rechercher un module et l'installer. Vous pouvez aussi

spécifier la version du module ainsi que des options si nécessaire.

& Available Packages X
(Q~ beau
beautiful-soup @ pesciption
| Screen-scraping library
Version
453
Author
Leonard Richardson
mailtoleonardr@seafault org
hitp iwww.crumm
() Specify version | 4.5
Options --user
m ‘ HomgeToporons

Si vous travaillez sur un ordinateur de la salle informatique, vous devez indiquer I'option —user

afin d’installer le module seulement pour l'utilisateur connecté.

’ Une documentation des commandes disponibles avec pip est accessible a I'adresse
https://pip.pypa.io/en/stable/
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27. Vous pouvez aussi installer les modules en utilisant le terminal de I'ordinateur.

Terminal

+ Microsoft Windows [version 10.0.14393]

X

(c) 2016 Microsoft Corporation. Tous droits réservés.

(E:\Anaconda\envs\python36) E:\Switch_Drive\Informatique_ 2\Exercices\Demo>pip3 install mcdule_name --user

P 4Run @ 6&TODO 5 Python Console [ Terminal
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Trucs et astuces
28. Auto-complétion PyCharm propose un systéme d’auto-complétion qui permet de faciliter
I'utilisation de nombreux modules.

import math

phrase = "Hello world!
print (phrase)

for i in range(len(phrase)):
print(i*" "+phrase[i])

a = math.|
acos (x) math

Press Ctrl+Point to choose the selected (o first) suggestion and insert a dot afterwards >>/T0

Lorsque vous écrivez, le logiciel vous propose les différentes possibilités selon ce que vous
écrivez. Les différentes variables et fonctions contenues dans un module vous sont aussi
proposées. Il vous est donc possible de choisir une des propositions et celle-ci sera écrite

automatiquement.

29. Documentation Pycham propose également d’avoir acces a de la documentation concernant
une variable ou une fonction. Pour cela, placez votre curseur sur un élément et allez dans

I'onglet View > Quick Documentation®

import math

phrase = "Hello world!"
print (phrase)

for i in range(len(phrase)):
print(i*" "+phrase([i])

a = math.cos (math.pi)
Documentation for cos(x) »

+ B < Python 3.6.0 (E:\Anaconda\envs\python36\pyth... %

Inferred type: (x: Real) -> float

cos(x)

Return the cosine of x (measured in radians).

30. Définition de fonction Vous pouvez accéder a la définition d’une fonction ou d’une variable.
Pour cela, placez votre curseur sur un élément et allez dans View > Quick Definition.

3 P . . ..
Vous pouvez aussi utiliser les raccourcis clavier associés.
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import math

Hello world!"

phrase =

for i in range(len(phrase)):
" iphrase(1])

h.cos (math.pi)

Definition of pi »

& math.py < Python 3.6.0 (E:\Anaconda\envs\python36\python.exe) >

bt = 3.141592653589793

Vous pouvez obtenir un accés complet au fichier ol I'élément est défini. Pour cela, utilisez le
raccourcis CTRL + Clic gauche sur Windows (ou CMD + Clic gauche sur MAC) en cliquant sur
I’élément souhaité. Le fichier contenant la définition de I’élément s’ouvrira dans I'éditeur de
texte. Cela est trés utile si vous voulez retrouver et changer la valeur d’une variable ou la
définition d’une fonction.

Vous pouvez faire en sorte de voir la définition d’'un élément en passant votre souris sur celui-
ci. Pour cela, allez dans I'onglet File > Settings, puis dans I'onglet Editor > General. Ici, cochez
la case Show quick documentation on mouse over.

B Settings X
A 3 .
@ ) Editor > General Reset
Abpeatace & Betavios K2 Enable Drag'n'Drop functionality in editor
Keymay
Shling Soft Wraps
Editor

[ Use soft wraps in editor

Colors & Fonts Additional shift:

Code Style
Inspections
File and Code Templates
File Encodings
Live Templates
File Types
Emmet
Images
Intentions
Language Injections
Spelling
TexMate Bundles
TODO
Plugins
Version Control
Project: Serie_1
Build, Execution, Deployment
Languages & Frameworks
Tools

Virtual Space
(] Allow placement of caret after end of line
[CJ Allow placement of caret inside tabs

[ Show virtual space at file bottom

Other

Strip trailing spaces on Save: Modified Lines
[J Ensure line feed at file end on Save
Show quick documentation on mouse move Delay (ms): | 500

Highlight modified lines in gutter

Different color for lines with whitespace-only modifications

Highlight on Caret Movement
Highlight matched brace

[J Highlight current scope

} Cancel | | apply | | Help

31. Refactoring Pycharm permet d’utiliser des refactors, qui permettent de modifier facilement
votre code. Pour cela, faites un clic droit sur un élément et affichez les Refactors. Selon
I’élément sur lequel vous cliquez, différents refractors seront disponibles. Sur une variable,
vous pouvez par exemple la renommer : cela la changera dans tous votre script.
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import math

phrase = "Hello world!"
print (phrase)

for i in range(len(phr p =
Copy Reference Ctrl+Alt+Maj+C

print(i*" "+phrase
[l Paste Ctrl+V
a = math.cos(math.pi) Paste from History... Ctrl+Maj+V
print(a) Paste Simple Ctrl+Alt+Maj+V
Column Selection Mode Alt+Maj+Insérer
Find Usages Alt+F7
Folding » Change Signature... Ctrl+F6
GoTo » Move... F6
Generate... Alt+Insérer Copy... F5
s Safe Delete... Alt+Supprimer
P Run 'Demo’ Ctrl+Maj+F10
#% Debug 'Demo’ Extract b
¥% Run 'Demo’ with Coverage Inline... Ctrl+Alt+N
5p Profile 'Demo’ Pull Members Up...
=§ Concurrency Diagram for 'Demo’ Push Members Down...
@ Save 'Demo’ Convert to Python Package

B Convert to Python Module
Local History »

16



